PDA

View Full Version : T....rebuilt engine, oil pressure sky high...wtf


2_fast_240
04-08-2008, 01:19 AM
And I mean 100+ psi at idle high. :eek:

From the begining... Today I got to start my ka-t for the first time! (built block, stock head). So, I pull the coil wire and fuel pump fuse, and after about 4 or 5 times cranking for a couple secs. each, the oil pressure starts coming up quite steadily. I saw it hit 20 and stopped there.

Hook everything back up and go to start it. Fired up within the 1st crank, and out of the corner of my eye, I see the oil pressure needle wrap completely around the gauge which reads to 100 (autometer mech. gauge). I immediatly turn it off and tell my dad what I saw (who was under the hood about to set the timing). We decided to pull the coil wire and fuel pump fuse again and crank it to see how high it would go with no fuel/spark. It went a little over 30 psi. So we try it again, and same thing... 100+ psi instantly.

Also, this is not a new oil pump. I ran it before for ~6k miles. However, I had no gauge before, so its possible it was like that before.

Im hoping its just a faulty gauge. A guy at my work is suppose to loan me another gauge tom. so ill see how that goes.
If its not that, im guessing it the oil pressure regulator. Or mabey a piece of dirt or something in the oil passages ( doubt that though).

Any other ideas? Im all ears

On a side note, damn that 3" ebay exhaust sounds soooo much better w/ a turbo in front of it. lol


Oh yea, you can check my complete set-up here. http://www.ka-t.org/forums/viewtopic.php?t=30341

Also forgot to mention, I did not mess with the regulator at all when the engine was apart. Just cleaned the pump. and filled it with engine oil. I also filled the oil filter with oil.

And one more question. Ive got a knock lite and it was shinning red while I was cranking. I never set it though, so it never learned my engines sound. Im hoping this is noraml. Any insight from someone who has a knock lite would be greatly appreciated.

Sorry for such a long post btw... just wanna get this thing on the road!

verge513
04-10-2008, 02:30 PM
with youre car running high oil pressure like that im sure its your oil pressure relief valve..its pretty much just a ball with a spring on it when to much oil pressure is present it pushes open and by passes ur oil back to the oil pan.. i just rebuilt mine to but was sure to make sure i could move the ball..it seems to be the only problem i can think of...on the ka.. its behind the oil filter neck..just take off the oil filter.. and tthe extension neck..its just 4 bolts.. i believe either 12 or 14mm ..as far as cleaning just try to push the ball it...if u can get it to open enough spray carb cleaner or somthing in that nature.. if its still hard or just cant get it to feel smooth..just replae it..its a really cheap fix..hope this helps...as far as the knock light. it would light when u crank.. its normal no biggie.. just worry if it goes off wile driving hard...with rebuilt engine im sure you checked all the tolerances of the wrist pins and put all new bearings in. if you did..it shouldnt knock at all...i would turbo mine..man almost more money than what my s14 is worth..

verge513
04-16-2008, 06:51 PM
get it fixed man?

2_fast_240
05-13-2008, 03:54 AM
Oh man, sorry to leave ya hangin here. Im always on ka-t.org now for obvious reasons.

But, yea, turned out it was the oil pressure regulator. The little valve was stuck. Major PITA to get out.
I know it came from this stupid parts cleaner we have at my work. Leaves a film behind and when it dries up it gets all crusty.
Took it apart, scotch bite+wd40=like new.

Car now runs pretty good and pulls hard. But im having major AFR problems.
I just wanna get everything tweaked in so I can hit up the drag strip.

SleeperSx
05-15-2008, 09:53 AM
Glad you found it. What kind of times are yooking for? any suspention work setup for the drag?

2_fast_240
05-16-2008, 10:35 AM
Well, im not really too worried about times until I get it running right. If I dont at least get mid 8's when all is clicking though, ill be a little upset. (1/8th mile).

Right now im researching swaping subframes and all that jazz since its a hicas car. From what I hear your limited to 9" wide wheels with the hicas subframe so im not gonna do the lock bar. Im also gonna get the slp aluminum subframe bushings mabey the differential to subframe bushings. Probably a helical lsd. Mabey welded diff. And I want the HKS drag coilovers but im not sure if they make them for our cars. Gotta look into that as well.