PDA

View Full Version : weird overheating problem


Mikey213
03-13-2008, 11:46 AM
When i drive my temp guage would rise all the way to the top and stay there for about a min then itll go back down to normal temp... then itll rise up again the next 20-40 min and over n over I don't know what the problem is. =0( As it overheats i notice the rpms raise up just a mm above 1,000rpm I have a koyo rad, nismo thermostat, and new belts. Is it the water pump? i have a cheap ass autozone radiator cap.... or could it be that my lower chain guide is cracked and itll randomly slows down the chain causing it to heat up a bit?? i hope it's etheir of those and NOT MY HEAD GASKET =0(

Skaterjunky8
03-13-2008, 12:06 PM
could be a glitchy temp sensor. check that out first. or let it sit and see if it actually over heats while the gauge is in the red

Air
03-24-2008, 12:04 PM
sounds like a headgasket to me. I had this issue with my car and couldnt figure it out. It wouldnt overheat at idle, but as soon as i put load on the motor it began to overheat.

98s14inaz
03-24-2008, 12:25 PM
Ka's are temperamental. First check your oil and water and make sure they aren't contaminated with each other (water/coolant + oil = chocolate milk...also look to see if there are any oil rainbows in your water, good indication if you are about to have a hg go.). Next do a compression check and leak down test. Then check the sensors. Water pump and or thermostat could be a likely candidates as well. Lastly check you radiator for build up or just replace it all together. 240 owners are plagued with what previous owners did or didn't do to their cars.

Sir
03-24-2008, 01:25 PM
if it goes up than down shortly after, its just an air bubble.

you could use something like this to make your life easier.
http://cgi.ebay.com/ebaymotors/Mityvac-MIT4700-Air-Evac-Purge-Test-System-COOLANT_W0QQitemZ280129088590QQcmdZViewItem?hash=i tem280129088590&_trksid=p3286.m20.l1116