PDA

View Full Version : tick tick tick. what the hell is it?


louisdaboois
02-20-2008, 12:42 AM
ok, well.... rebuilt my ka about 6 months ago, everything is sweeeeeet. almost 10k miles on it now and no problems besides a small rear main seal leak. one thing that has been bothering me is an annoying ass clicking sound coming from the valve cover. It's not the ordinary timing chain rattle, it's further back of the head. plus, i replaced all of the timing stuff and removed the unnecessary guides. read many threads on here about people with sr's hearing the same noise, but usually ends with a loud squealing sound. mine just taps excessively. I threw the valve cover off, just to make sure that the head is getting sufficient oil. everything looks normal, no scoring on the cam lobes, valve seats seem to be fine, caps are nice and tight and everything's smothered in oil. the noise is rpm based as well. I just hear it at idle, once the rpm's increase the noise gradually deminishes. It doesnt effect performance, drives normal cruising and under boost. It's a 93' (dohc ka-t) (s13). It's just annoying, help me out homies. thanks.

ps. oil level is fine, doesnt burn oil, etc etc

Impact Drift
02-20-2008, 12:43 AM
sounds like a floating valve.

louisdaboois
02-20-2008, 12:54 AM
i dont know man. wouldnt you hear the sounds of a floating valve under load, rather than idle? lets say that road noise and exhaust isnt a variable.

Impact Drift
02-20-2008, 01:02 AM
i dont know man. wouldnt you hear the sounds of a floating valve under load, rather than idle? lets say that road noise and exhaust isnt a variable.

you should be able to. It's just hard to diagnose the problem from the internet. It sounds like a valve problem though. Usually a warped valve will cause misfires but the floating valve will give you the pure pinging sound. I'm guessing the floating valve. But you're 100% right that it should only be heard under load. I just can't think of anything else.

BusBOy
02-20-2008, 01:12 AM
It could also be your lifters.. you might have to bleed them.

BusBOy
02-20-2008, 01:30 AM
heres a link to see how to fix it.

http://forums.nicoclub.com/zerothread?id=215864&postid=2266507

smurfgcr
02-20-2008, 01:41 AM
it does sound a lot like the lifters needing to be bled. i tried this when i rebuilt my ka because i had that same noise and it definatly got more quiet after. didnt completely get rid of the noise but then again i wasnt too patient with the whole process.

Nismoknightska-t
02-20-2008, 02:57 AM
ka's are loud..!!

its your head built??

louisdaboois
02-20-2008, 09:21 AM
It could also be your lifters.. you might have to bleed them.

it's a dual cam, they dont have hydro lifters.

ka's are loud..!!

its your head built??

no, just a stock rebuild.