PDA

View Full Version : Brand new turbo


Driftapparel.com
02-19-2008, 12:30 PM
I just replaced my t-25 with another brand new t-25 and broke it in for about 85-90 miles. I boosted a lil on the way to work today and the car started making weird sputtering sounds and is idling very rough. It actually stalled at the next light and I was able to baby the rest of the way. The car had little power is was weak.

I checked intake sensor and it was still in place. holy crap what happened!?

Thanks guys!

dirtdiggler666
02-19-2008, 12:31 PM
where did you get the turbo???

boogerlovers
02-19-2008, 12:32 PM
boost leak...??? maybe you blew a coupler off...that could explain the rough idle and stalling

Driftapparel.com
02-19-2008, 12:32 PM
my buddy got it somewhere in la for 350 bucks ill call and ask him. thanks.

Driftapparel.com
02-19-2008, 12:35 PM
boost leak...??? maybe you blew a coupler off...


I looked under the hood and couldnt see anything right away however I was late for work and had to get in. everything externally looked fine.

I appreciate the help

azndoc
02-19-2008, 12:37 PM
The whole brand new T-25 has me doubting already about the actual quality of the turbo. Prolly egay shit.

txrxs
02-19-2008, 12:38 PM
You're not gonna like this...but if you have no coupler or other issues, sounds to me like the turbo is shot. After the car started to eat shit did you notice any smoke coming from the turbo housing itself? Is your car smoking?

Grenade180sx
02-19-2008, 12:40 PM
sorry to get off topic but im right over in beaumont hehe

we should have a get together sometime..

i work at Morongo :(

Driftapparel.com
02-19-2008, 12:47 PM
cool well it has a warranty so if that is it I wont be too upset but yeah I have done the work myself and its alot of work. I am definately not happy. Anything else it might be?

Driftapparel.com
02-19-2008, 12:48 PM
sorry to get off topic but im right over in beaumont hehe

we should have a get together sometime..

i work at Morongo :(

Awesome im at work right now right off the 10 down the 111! thats like 10-15 min away! definately

SoSideways
02-19-2008, 12:55 PM
No oil pressure to the turbo thus causing it to kind of seize?

dirtdiggler666
02-19-2008, 01:03 PM
yes when i heard brand new t25 i got a little worried

lets just hope its not made in china:rant:

Driftapparel.com
02-19-2008, 01:05 PM
No oil pressure to the turbo thus causing it to kind of seize?

yeah that scares me because I had to have a custom hose made for the oil line and I thought it was a little wierd.

downshift_sideways
02-19-2008, 01:05 PM
made in china lol.

Check all your couplers and vacuum hoses routing to the intake manifold.

Carb cleaner is your friend. Or soapy water. Check for any boost leaks.

Driftapparel.com
02-19-2008, 01:06 PM
yes when i heard brand new t25 i got a little worried

lets just hope its not made in china:rant:

lol well I guess it's actually a rebuilt one if that is any better.

Driftapparel.com
02-19-2008, 01:08 PM
made in china lol.

Check all your couplers and vacuum hoses routing to the intake manifold.

Carb cleaner is your friend. Or soapy water. Check for any boost leaks.

awesome! thanks! as soon as I go on my lunch I will souble check everything.

I appreciate everything guys keep it comming!

Driftapparel.com
02-19-2008, 01:28 PM
ok well I just checked all the couplers and they are fine. the oil line to the turbo seems to be leaking slightly (very slightly) (a little bit is around the inlet into the turbo.

downshift_sideways
02-19-2008, 01:31 PM
uh oh.

Might want to take out the inlet and check your turbo.

Driftapparel.com
02-19-2008, 01:34 PM
uh oh.

Might want to take out the inlet and check your turbo.

yeah i was definately going to do that. would I see the impellar siezing?