PDA

View Full Version : Odd richness problem...


sunnys14
02-13-2008, 11:25 PM
Built KA-T
AFR's are fine while cruising while engine isnt totally warmed up (13.6-14.5). After it reached operating temperature, cruising AFR's go from 11.5-13.9 up and down. At WOT its 11.5 no matter if the engine is cold or warmed up all the way, so it cant be a boost leak. Checked for boost leaks and nothing. Changed the O2 sensor, new CTS, plugs, wires, cap and rotor. Wideband sensor is also fairly new.

Not sure what the problem is... is the the TPS going bad? Car thinks that its WOT sometimes when its not (hence afr's dropping to 11.5 sometimes). But the problem only happens after ive been driving for about 10 minutes. Happens ONLY during cruising and out of boost, WOT is fine (AFR's 11.5 and no bucking). No power loss either...

Kouki
02-14-2008, 08:44 AM
Maybe you need to tune for cruising load and rpm, instead of just full throttle tune.

sunnys14
02-14-2008, 01:33 PM
its an enthalpy tuned ecu...

Koopa Troopa
02-14-2008, 02:05 PM
Built KA-T
AFR's are fine while cruising while engine isnt totally warmed up (13.6-14.5). After it reached operating temperature, cruising AFR's go from 11.5-13.9 up and down. At WOT its 11.5 no matter if the engine is cold or warmed up all the way, so it cant be a boost leak. Checked for boost leaks and nothing. Changed the O2 sensor, new CTS, plugs, wires, cap and rotor. Wideband sensor is also fairly new.

Not sure what the problem is... is the the TPS going bad? Car thinks that its WOT sometimes when its not (hence afr's dropping to 11.5 sometimes). But the problem only happens after ive been driving for about 10 minutes. Happens ONLY during cruising and out of boost, WOT is fine (AFR's 11.5 and no bucking). No power loss either...

Once the engine warms up the AFR's will go up as there is less fuel being given because the ECU will dump fuel to help the motor warm up. When you're just driving AFR's will go all over the place because the slightest touch of the throttle will have the TPS send a voltage signal to the ECU to tell it how much fuel to give. 13.9 is pretty rich for just cruising though...

When I'm just driving I usually see numbers from 14.6 - 17.8.. Once I get back those numbers will change though. Remember that the lower that number the more fuel you're wasting...

Your tune is fine.. The only problem with it is it's a ROM tune and they obviously went rich to be safe.

sunnys14
02-14-2008, 02:23 PM
there has to be something wrong, at 15% throttle on the freeway doing a constant 70mph, the afrs go from 13.9 to 11.5, back and forth slowly, in a matter of seconds...

Koopa Troopa
02-14-2008, 02:34 PM
Yeah, it's suppose to do that. I'd worry if it did that during boost though. If you're not rolling in boost then don't worry about it..

sunnys14
02-14-2008, 03:11 PM
The problem is i've been getting about 17mpg now due to unstable AFRs. This hasnt happened before. Usually i get about 23mpg on the freeway with constant stable AFR's.

Z U L8R
02-14-2008, 03:20 PM
i'd say get an safc2 and get it on a dyno that can put load on it.

Dave