PDA

View Full Version : ka24de cr4pped out overnight need help!!!


thafriendlypimp
11-26-2007, 08:09 PM
So, I have an '89 240sx cpe xe with a '91 ka24de swap. I just replaced myy front bumper and was checking the lights, then the next day it wouldn't fire up.
It could be my starter, but the engine DOES turn over.
I have checked fuel to the engine which is fine...
Checked spark from plugs OK
Checked compression in each cylinder looking good.
Also, checked and cleaned the distributor points...

This all started because my MAF was dying and before I could replace it i believe it did die. Now, I got one that works, but the car has yet to turn on. There are no loose wires or any messed up connections (except for the ghetto wiring to the lights which I need to checkout)... however, the car ran fine for the past 3 months that I've had it.

Any suggestions? Or similar problems? My friend has been helping me (a mechanic) and there are no other explanations we know of. Could it be another sensor that just malfunctioned out of nowhere? Forgot to mention, when retarding the distributor all the way back and slowly advancing it then it tries to fire up but with not much force. Battery is fully charged and even tried everything with a jump start. But to no avail I have to weep for now. Help is appreciated!

aznpoopy
11-26-2007, 08:50 PM
it sounds like your timing is off a tooth

which would be real weird if it was working before and you haven't removed the distributor

thafriendlypimp
11-26-2007, 11:32 PM
sounds like something i've heard too. Could it be that I shorted the ECU? I think maybe I did when removing the power source for the "ghetto wiring".

thafriendlypimp
02-12-2008, 11:55 PM
Just so everyone knows... I have finally found a solution to my problem. It was the distributor... i think it's called the pickup coil or something like that was faulty. So i picked up a new one and now the car runs. Timing was never off a tooth like i suspected it wasn't