Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 01-29-2013, 11:35 PM   #1
todd5854
Leaky Injector
 
Join Date: Nov 2012
Location: Pennsylvania
Posts: 143
Trader Rating: (0)
Feedback Score: 0 reviews
s13 cruise control acting up

Stock KA... swapped it manual, and there was a relay I was told to remove and jumper to get the cruise control to work again. I found 5 different guides, and they all said to jumper the same one, so that's what I did. Worked fine for the first two months

Now, when I turn it on, lets say im doing 70... if i press "set" it drops to 65. and maintains it for a little while. If I press and hold accel, no matter what it will accelerate to 70 and no more. if I hold it until it reaches 70 and then let go, it still drops to 65.

I checked where it connects to the throttle body, there is a nice tight cable connected..

My first thought is the vacuum pump / diaphragm is going bad. does that borrow vacuum from the cars system? Or does it use its own? hopefully its own....
todd5854 is offline   Reply With Quote
Sponsored Links
Old 01-30-2013, 12:54 PM   #2
todd5854
Leaky Injector
 
Join Date: Nov 2012
Location: Pennsylvania
Posts: 143
Trader Rating: (0)
Feedback Score: 0 reviews
anyone...?
todd5854 is offline   Reply With Quote
Old 01-30-2013, 01:15 PM   #3
Mikester
Nissanaholic!
 
Mikester's Avatar
 
Join Date: Jun 2007
Location: St. Louis, MO
Posts: 1,858
Trader Rating: (0)
Feedback Score: 0 reviews
258 Auto Speed Control Device :: Body Electrical :: Genuine Nissan Parts :: 240SX Parts (S13) 1989-1994 :: Nissan Parts, NISMO and Nissan Accessories - Courtesyparts.com
__________________
Mikester is offline   Reply With Quote
Old 01-31-2013, 11:04 AM   #4
todd5854
Leaky Injector
 
Join Date: Nov 2012
Location: Pennsylvania
Posts: 143
Trader Rating: (0)
Feedback Score: 0 reviews
So you think I need the actual control module? I thought for sure it was that vacuum diaphragm, or maybe its pump
todd5854 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2014, Zilvia.net™