Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 01-25-2013, 10:21 PM   #1
likeaboss240
 
Join Date: Nov 2012
Location: Alberta, Canada
Posts: 6
Trader Rating: (0)
Feedback Score: 0 reviews
Exclamation Rear Upper Control Arm Allignment Issue

Hello, before i start my car is a 1993 240sx coupe with a stock suspension. So i hit a curb a while ago, snapped my rear traction arm, and bent my lower control arm, took it all apart and had to remove one of the bolts from the upper control arm to get the bolt from the traction arm out. So parts arrived, put on the new traction arm and new lower control arm but now i cant seem to get the holes for the upper control arm to line up, the bushing is too far back for the arm so its almost like the arm is too long... Does anyone know what couldve happened? Is it common? How do i get it to line up so i can get the bolt back in? Any help appreciated.
Thanks
likeaboss240 is offline   Reply With Quote
Sponsored Links
Old 01-27-2013, 01:10 AM   #2
Mikester
Nissanaholic!
 
Mikester's Avatar
 
Join Date: Jun 2007
Location: St. Louis, MO
Posts: 1,805
Trader Rating: (0)
Feedback Score: 0 reviews
Un-do the rear shock from the spindle with a jack under the rotor... Wiggle it into position, put bolt thru... Lube the shank of the bolt, not the threaded part.
__________________
Mikester is offline   Reply With Quote
Old 01-27-2013, 09:23 AM   #3
Croustibat
Zilvia FREAK!
 
Join Date: Aug 2011
Location: France - Toulouse
Age: 34
Posts: 1,297
Trader Rating: (0)
Feedback Score: 0 reviews
Hit a kerb => check your subframe is not bent too ... it happens quite often on these cars.
Croustibat is offline   Reply With Quote
Old 01-27-2013, 10:01 PM   #4
likeaboss240
 
Join Date: Nov 2012
Location: Alberta, Canada
Posts: 6
Trader Rating: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by Croustibat View Post
Hit a kerb => check your subframe is not bent too ... it happens quite often on these cars.
I know, i think i got lucky, everything other than the parts that broke/bent looks good.
likeaboss240 is offline   Reply With Quote
Old 01-30-2013, 12:45 PM   #5
likeaboss240
 
Join Date: Nov 2012
Location: Alberta, Canada
Posts: 6
Trader Rating: (0)
Feedback Score: 0 reviews
So i losened the bolts and got it to move into where the bolt can be inserted, now does anyone have the torque specs for the rear suspension (including sway bar) its impossible to find.
Thanks for the help.
likeaboss240 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2014, Zilvia.net™