Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , and Lx series.


Reply
 
Thread Tools Display Modes
Old 02-25-2012, 03:36 PM   #1
PantsOnTheGround
Leaky Injector
 
PantsOnTheGround's Avatar
 
Join Date: Feb 2012
Location: tennessee
Age: 22
Posts: 83
Trader Rating: (0)
Feedback Score: 0 reviews
Exclamation rb20 turbo spooling but not making boost!?

hey guys. so yesterday i swapped out my stock rb20 turbo for a newerish rb20 turbo (because it was only $160) and after getting everything hooked back up right i took it for a test drive and it barely made much power. one thing i did notice were that a couple bolts that hold the cold side of the turbo from turning were loose but i couldnt get to them. everything else was tight. what would cause the turbo to spool up but not create any boost? im stumped!
PantsOnTheGround is offline   Reply With Quote
Sponsored Links
Old 02-25-2012, 04:31 PM   #2
ultimateirving
Zilvia FREAK!
 
ultimateirving's Avatar
 
Join Date: Nov 2010
Location: arizona
Age: 27
Posts: 1,159
Trader Rating: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by PantsOnTheGround View Post
hey guys. so yesterday i swapped out my stock rb20 turbo for a newerish rb20 turbo (because it was only $160) and after getting everything hooked back up right i took it for a test drive and it barely made much power. one thing i did notice were that a couple bolts that hold the cold side of the turbo from turning were loose but i couldnt get to them. everything else was tight. what would cause the turbo to spool up but not create any boost? im stumped!
Stuck / Bad wga. I'd start there. See if ur wastegate arm moves freely
__________________
Sr20det-z33trans-e85-2871r-Ksport coils.
Facebook.com/Desertstreetscene
ultimateirving is offline   Reply With Quote
Old 02-25-2012, 04:50 PM   #3
PantsOnTheGround
Leaky Injector
 
PantsOnTheGround's Avatar
 
Join Date: Feb 2012
Location: tennessee
Age: 22
Posts: 83
Trader Rating: (0)
Feedback Score: 0 reviews
The wga arm moves freely. I did find a 90 degree nipple on my old turbo that looks like it could run to a vacuum, so I put it on the new one. Also found a loose bolt on the hot side of the turbo so I'm gonna tighten that and try again
PantsOnTheGround is offline   Reply With Quote
Old 02-25-2012, 05:28 PM   #4
PantsOnTheGround
Leaky Injector
 
PantsOnTheGround's Avatar
 
Join Date: Feb 2012
Location: tennessee
Age: 22
Posts: 83
Trader Rating: (0)
Feedback Score: 0 reviews
found the issue i believe. this should help out anybody that is new to turbo swapping like myself. there was a stock 90 degree nipple on the inlet side of the turbo and i had forgotten to put it on the new turbo so it was losing all the boost pressure through that vacuum hole. also i noticed there were a couple loose bolts on the hot side so i tightened those up and it ran fine. can someone help me out and tell me what the use for that nipple is? right now im using the wastegate vacuum nipple to run my boost controller but can i use the turbo one for anything?
PantsOnTheGround is offline   Reply With Quote
Old 02-25-2012, 06:37 PM   #5
KiLLeR2001
Post Whore!
 
Join Date: Jun 2007
Location: オーランドフロリダ
Posts: 6,187
Trader Rating: (30)
Feedback Score: 30 reviews
Check ignition timing.
__________________


NissanPure.com
KiLLeR2001 is offline   Reply With Quote
Old 02-26-2012, 08:30 AM   #6
nomoremk2
Zilvia Member
 
Join Date: Sep 2010
Location: South jersey
Age: 24
Posts: 293
Trader Rating: (1)
Feedback Score: 1 reviews
^Did you even read the thread? That nipple could be used for anything you need a boost source for. To simplify things you could run your wastegate/boost controller setup from that.
nomoremk2 is offline   Reply With Quote
Reply

Bookmarks

Tags
rb20, rb25, s13, turbo


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2014, Zilvia.net™