Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 04-25-2018, 08:56 AM   #1
irbamzenki
 
Join Date: Oct 2015
Location: Turkey
Age: 30
Posts: 5
Trader Rating: (0)
irbamzenki is an unknown quantity at this point
Feedback Score: 0 reviews
My SR20det let me down.Help me SR gods.

Hi i have a 1996 s14 sr20det zenki . I have a serious problem lately and i cant find any people who has similar problem.

Problem is when i drive my car engine tends to stall under 3k rpm.İt doesnt matter which gear i am in . For example if i drive on the road 3rd gear it pulls great but when i drive normal and rpm drops under 3k car starts to shake and try to stall. Or i am driving on highway on 5th gear downhill! and rpm drops under 3 k car starts to shake and try to stall.İ cant find the problem.Other than car pulls great at steady afr. My specs are

sr20det with vtc (s14 version)

oem engine
fmic
tial bov
tial external vaste gate
oem injectors
aem fpr
walbro450
audi r8 coil pack
stand alone ecu( with map reading , i dont use maf)
innovate afr
exedy stage 4 clutch
rocker arm stopper
cometic head gasket

Recently built engine.I am suspecting from timing or worn out camshafts.Or fuel pump.

What is your opinions?

thanks for your help. Great communuty.
irbamzenki is offline   Reply With Quote
Sponsored Links
Old 04-25-2018, 09:18 AM   #2
jedi03
Zilvia FREAK!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,146
Trader Rating: (8)
jedi03 is on a distinguished road
Feedback Score: 8 reviews
fuel maybe...what are your AFRs? could be IACV too...
jedi03 is offline   Reply With Quote
Old 04-25-2018, 10:26 AM   #3
brndck
Premium Member
 
brndck's Avatar
 
Join Date: Jun 2003
Location: costa mesa, ca
Age: 36
Posts: 10,661
Trader Rating: (122)
brndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfection
Feedback Score: 122 reviews
Send a message via AIM to brndck
vacuum leak. check it.
__________________

http://outslidersandsmokeproduce.blogspot.com/
Quote:
Originally Posted by Mannykiller View Post
it'll fit JANK.. and no one likes Jank except Broke ass zilvians.
brndck is offline   Reply With Quote
Old 04-26-2018, 06:43 AM   #4
irbamzenki
 
Join Date: Oct 2015
Location: Turkey
Age: 30
Posts: 5
Trader Rating: (0)
irbamzenki is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by jedi03 View Post
fuel maybe...what are your AFRs? could be IACV too...
afr is around 11-12 when i pull... between 13-14 when normal driving. IACV deleted.
irbamzenki is offline   Reply With Quote
Old 04-26-2018, 06:44 AM   #5
irbamzenki
 
Join Date: Oct 2015
Location: Turkey
Age: 30
Posts: 5
Trader Rating: (0)
irbamzenki is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by brndck View Post
vacuum leak. check it.
well i will check it but can a vacuum leak effect this bad ? car wants to stall at 3k rpm when i go downhill
irbamzenki is offline   Reply With Quote
Old 04-26-2018, 07:57 AM   #6
EFITTZY
Zilvia Member
 
EFITTZY's Avatar
 
Join Date: Mar 2016
Location: I n d i a n a
Age: 22
Posts: 189
Trader Rating: (0)
EFITTZY is making a name for him/her selfEFITTZY is making a name for him/her self
Feedback Score: 0 reviews
How long ago did it start? Any other issues you've run into w the rebuild that could contribute to your issue?

My thoughts would be a mean vac leak, or bad tps. Your afr's seem pretty spot on. What ems/standalone are you running?
__________________
(づ。◕‿‿◕。)づ T E A M B L O O M
EFITTZY is offline   Reply With Quote
Old 04-26-2018, 09:50 AM   #7
FweshStance
 
FweshStance's Avatar
 
Join Date: Aug 2017
Location: Massachusetts
Posts: 2
Trader Rating: (0)
FweshStance is an unknown quantity at this point
Feedback Score: 0 reviews
check for vacuum leaks
FweshStance is offline   Reply With Quote
Old 04-26-2018, 02:05 PM   #8
Kingtal0n
Post Whore!
 
Kingtal0n's Avatar
 
Join Date: Jul 2005
Location: South Florida
Age: 35
Posts: 4,105
Trader Rating: (17)
Kingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really niceKingtal0n is just really nice
Feedback Score: 17 reviews
Send a message via AIM to Kingtal0n
Nobody is reading it has a map sensor. a vacuum leak or boost leak isn't going to matter.

It is stalling. It needs tuning, including air control. set idle speed properly then tune it properly.
Kingtal0n is offline   Reply With Quote
Old 04-27-2018, 06:36 AM   #9
irbamzenki
 
Join Date: Oct 2015
Location: Turkey
Age: 30
Posts: 5
Trader Rating: (0)
irbamzenki is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by EFITTZY View Post
How long ago did it start? Any other issues you've run into w the rebuild that could contribute to your issue?

My thoughts would be a mean vac leak, or bad tps. Your afr's seem pretty spot on. What ems/standalone are you running?
My ecu is SPARK EMS.. Well when rebuilding we figured that camshaft profiles were a little worn out.. Car pulls great accelerate like hell but when decelerate its starts to shake on 3k rpm even downhill -_-
irbamzenki is offline   Reply With Quote
Old 04-27-2018, 06:38 AM   #10
irbamzenki
 
Join Date: Oct 2015
Location: Turkey
Age: 30
Posts: 5
Trader Rating: (0)
irbamzenki is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by Kingtal0n View Post
Nobody is reading it has a map sensor. a vacuum leak or boost leak isn't going to matter.

It is stalling. It needs tuning, including air control. set idle speed properly then tune it properly.
İt is already properly tuned thats why it pulls great with steady afr. We cant pin down the problem as it only makes when decelerating.
irbamzenki is offline   Reply With Quote
Old 04-27-2018, 07:06 AM   #11
s13silvia123
Post Whore!
 
s13silvia123's Avatar
 
Join Date: May 2006
Location: where waldo is
Age: 37
Posts: 3,117
Trader Rating: (14)
s13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfections13silvia123 is close to perfection
Feedback Score: 14 reviews
I had similar problems before but with my old Infiniti QX4. I had issues in and out for a few years where I also had misfires which would blow up the muffler. I would drive normal cruising on highways where it would stall. As you push the gas pedal it would not go pass a certain rpm. It turns out to be the cam angle sensor inside the distributor. I was thinking no it can't be since the the distributor was new. I checked again and also corrected the timing on it. Yeap, it did turn that it was the distributor after I replace the distributor. Ever since then, I had never had an issue again. But for the SR I would believe it would be the CAS.
__________________
18g and 20g turbo users click on me
http://zilvia.net/f/tech-talk/261219-18g-20g-turbo-users.html


Last edited by s13silvia123; 04-27-2018 at 11:34 AM..
s13silvia123 is offline   Reply With Quote
Old 04-27-2018, 09:28 AM   #12
jedi03
Zilvia FREAK!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,146
Trader Rating: (8)
jedi03 is on a distinguished road
Feedback Score: 8 reviews
you using correct CAS for your ecu? I know AEM is finicky...
jedi03 is offline   Reply With Quote
Reply

Bookmarks

Tags
s14, sr20det, stall, zenki


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™