Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 02-13-2018, 08:40 PM   #1
95se
Zilvia Junkie
 
95se's Avatar
 
Join Date: Dec 2002
Location: Arlington, TX
Posts: 372
Trader Rating: (0)
95se is an unknown quantity at this point
Feedback Score: 0 reviews
buzzing noise at startup and other odd noise

I have a stock KA with 215K on it with injen intake and nismo thermostat. I noticed shortly after I got my car back from steering rack rebuild I started hearing a rubbing kind of noise but here it mainly inside with the doors closed. I had 10W40 full synthetic in when it got down to 15F one night or two before I was able to change it to 5W30 since it was in the shop so long waiting on the rack to come back. Then couple of days ago I noticed this buzzing noise at startup which lasts about couple of minutes. Engine also is not warming up to normal temp and there is girgling in the coolant system. I would have thought it would be overheating. I went for a hard run couple of nights ago and it pulled like normal. It was cool enough to where I could touch the radiator cap right afterwards. Oh and the check engine light has been on for about a year because of the egr.
__________________
z32 front brakes, spl tc rods
95se is offline   Reply With Quote
Sponsored Links
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:22 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™