Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 04-16-2018, 10:34 PM   #1
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Cant Figure Out Speedo Problem....

Need some help and did some research and still can't figure it out.. heres everything I've done so far... swapped cluster twice (one was another dohc analog cluster and the other is a nx1600 digital cluster), i have swapped the VSS once (though if i get it working i will need to swap a sohc VSS so the cluster will read right so I'm gonna try to swap that next?) and still nothing... i was curious if anyone knew of anything else that i may have missed that i can try out, anything helps!
bigmj44 is offline   Reply With Quote
Sponsored Links
Old 04-16-2018, 11:40 PM   #2
afishysilvia
V-H8
 
afishysilvia's Avatar
 
Join Date: Jan 2010
Location: Cali
Posts: 763
Trader Rating: (13)
afishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to beholdafishysilvia is a splendid one to behold
Feedback Score: 13 reviews
Okay man we need more info than this? What year car? What engine? Manual/Auto Gearbox? Any mods or swaps done that you know of?
afishysilvia is online now   Reply With Quote
Old 04-16-2018, 11:49 PM   #3
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Shoot my bad forgot to put that in... so far lol it’s a 1993 and dohc stock manual... everything on motor is stock besides a lot of OEM upgrades like quest alternator, s14 slave etc but shouldn’t affect any of that... eventually I will be swapping the RB I’m building and go through this all over again (prolly get a Dakota converter to help with that)
bigmj44 is offline   Reply With Quote
Old 04-16-2018, 11:52 PM   #4
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
But when I got the car speedo never worked... and last 3 years been slowly coming back to it and just recently swapped the nx1600 cluster and speedo did work on the 1600 I saw it drive lol so I know it ain’t cluster and I also did another dohc cluster that I saw run too lol but I finally wanna get that small issue sorted out since I’ve dailyed for 3 years now like that and got use to just knowing how fast I’m goin in RPMs but def wanna see the nx1600 completely work
bigmj44 is offline   Reply With Quote
Old 04-17-2018, 08:25 AM   #5
jedi03
Zilvia FREAK!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,056
Trader Rating: (7)
jedi03 is on a distinguished road
Feedback Score: 7 reviews
so whats not working? you say speedo is not but in the last post it is...
jedi03 is offline   Reply With Quote
Old 04-17-2018, 03:53 PM   #6
staying_chuki
Leaky Injector
 
staying_chuki's Avatar
 
Join Date: Feb 2018
Location: Ocala Fl
Posts: 68
Trader Rating: (0)
staying_chuki is an unknown quantity at this point
Feedback Score: 0 reviews
Trace your wiring and inspect it all, never know what a n00b PO could have done.


Sent from my iPhone using Tapatalk
staying_chuki is offline   Reply With Quote
Old 04-17-2018, 11:00 PM   #7
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Quote:
Originally Posted by jedi03 View Post
so whats not working? you say speedo is not but in the last post it is...

I think u misread lol... I said the cluster worked on a running nx1600 before I pulled it and the speedo worked on it and same with the other anaolog cluster what on a different chassis and saw the speedo work but when I swapped them on my chassis the speedo didnít work... everything on the clusters work except the speedometer (and course odometer, trip, and if I had cruise control)
bigmj44 is offline   Reply With Quote
Old 04-17-2018, 11:03 PM   #8
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Quote:
Originally Posted by staying_chuki View Post
Trace your wiring and inspect it all, never know what a n00b PO could have done.


Sent from my iPhone using Tapatalk
Yea def gonna look over all the wiring again I guess that I can follow?... but will be seeing what happens if I pick up a sohc vss (one, so the nx cluster wonít read double as I hear many do.. and two, I read that if your plastic red gear pinon is damaged slightest it wonít read right.. when I saw mine it didnít seem damaged but maybe swapping with a diff pinon could solve it
bigmj44 is offline   Reply With Quote
Old 04-18-2018, 06:19 AM   #9
staying_chuki
Leaky Injector
 
staying_chuki's Avatar
 
Join Date: Feb 2018
Location: Ocala Fl
Posts: 68
Trader Rating: (0)
staying_chuki is an unknown quantity at this point
Feedback Score: 0 reviews
Cant Figure Out Speedo Problem....

Quote:
Originally Posted by bigmj44 View Post
Yea def gonna look over all the wiring again I guess that I can follow?... but will be seeing what happens if I pick up a sohc vss (one, so the nx cluster wonít read double as I hear many do.. and two, I read that if your plastic red gear pinon is damaged slightest it wonít read right.. when I saw mine it didnít seem damaged but maybe swapping with a diff pinon could solve it


Yeah my wiring is like respliced and messed up because the previous owner thought he could make the wrong speed sensor work. Mine has never worked i just got over it haha, but perfect example of PO screwin things up right there.


Sent from my iPhone using Tapatalk
staying_chuki is offline   Reply With Quote
Old 04-18-2018, 07:29 AM   #10
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Quote:
Originally Posted by staying_chuki View Post
Yeah my wiring is like respliced and messed up because the previous owner thought he could make the wrong speed sensor work. Mine has never worked i just got over it haha, but perfect example of PO screwin things up right there.


Sent from my iPhone using Tapatalk
Lol hell Ye true that man lol and I have noticed some hack jobs in this car in last 3 years and thereís more im still tackling tryin to make it legit again lolcye same but kinda wanna see the speedo again so I always come back to that mofo lol
bigmj44 is offline   Reply With Quote
Old 04-18-2018, 09:39 AM   #11
jedi03
Zilvia FREAK!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,056
Trader Rating: (7)
jedi03 is on a distinguished road
Feedback Score: 7 reviews
every 240 has its unique problem...and punctuation fixes a misread usually lol. I do recommend also check wiring especially if you saw it working in another vehicle. double check you are also using the correct speedo/cluster for your setup as I have heard of problems there too
jedi03 is offline   Reply With Quote
Old Today, 08:01 PM   #12
bigmj44
 
Join Date: Jun 2016
Location: Arizona
Age: 27
Posts: 15
Trader Rating: (0)
bigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choicesbigmj44 has made poor choices
Feedback Score: 0 reviews
Quote:
Originally Posted by jedi03 View Post
every 240 has its unique problem...and punctuation fixes a misread usually lol. I do recommend also check wiring especially if you saw it working in another vehicle. double check you are also using the correct speedo/cluster for your setup as I have heard of problems there too
Lol my bad man thanks for being cool bout it, yea for sure Iíll check all that and see whatís the deal, it seems wiring is the #1 issue people have
bigmj44 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.netô