Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 08-16-2014, 04:23 PM   #1
ariansarvi
 
Join Date: Aug 2014
Location: Toronto, Ontario
Posts: 2
Trader Rating: (0)
ariansarvi is an unknown quantity at this point
Feedback Score: 0 reviews
s13 S13 KA-T Problems :( HELP PLEASE

Hey everyone, new here and wanted to see if anyone could possibly help me with my problems.

Specs:
- 92' 240sx KA-T
- T3/T4 Turbo
- 3 inch exhaust
- Stock ECU
- FMIC
- Prob around 300hp

1st problem: this is recent and not every single time, I'm driving and at slow speeds it just turns off, then it doesn't turn on but cranks for like 30 seconds then turns on again. Note: my dad took it for a drive and he didn't know and put 89 octance. I'm thinking it's a fuel problem, maybe not getting fuel. Please help.

2nd Probelm: When I'm coming to a stop or just slowing down and I put it in neutral, the car does, only in neutral this happens, what I tend to do is right when I ear it's about to die I throw it in first or second then the rpm goes back up.

3rd Problem: I have a boost gauge and A/F ratio guage. The boost gauge seeks fine, the A/F plays a little too much I think, it's not really steady at idle it's around 14-14.3. When I drive sometime it goes crazy and goes all over the place. Also side note, what is "Peak" for my boost gauge and A/f ratio there's a button that turns on "peak" what is it? And should it always be on?
ariansarvi is offline   Reply With Quote
Sponsored Links
Old 08-17-2014, 12:31 PM   #2
Croustibat
Nissanaholic!
 
Join Date: Aug 2011
Location: France - Toulouse
Age: 37
Posts: 1,829
Trader Rating: (0)
Croustibat is an unknown quantity at this point
Feedback Score: 0 reviews
Your problems:
1/boost leak
2/maxed MAF and/or injectors, maybe dying fuel pump
3/no tune

Fix 1 & 2, then have someone fix #3 for you. Do it before it is too late, if it is not already.
Croustibat is offline   Reply With Quote
Old 08-17-2014, 02:40 PM   #3
ariansarvi
 
Join Date: Aug 2014
Location: Toronto, Ontario
Posts: 2
Trader Rating: (0)
ariansarvi is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by Croustibat View Post
Your problems:
1/boost leak
2/maxed MAF and/or injectors, maybe dying fuel pump
3/no tune

Fix 1 & 2, then have someone fix #3 for you. Do it before it is too late, if it is not already.
Thanks for the information, it is very much appreciated.
So putting into consideration the specs of my car I have listed above, what size / brand injectors do you recommend. Also MAF and fuel pump, what is good to buy?
ariansarvi is offline   Reply With Quote
Old 08-17-2014, 03:16 PM   #4
Frank_Jaeger
Zilvia FREAK!
 
Join Date: Jan 2012
Location: Port Charlotte, Florida
Age: 26
Posts: 1,351
Trader Rating: (1)
Frank_Jaeger is an unknown quantity at this point
Feedback Score: 1 reviews
Get some 720cc injectors, any brand. Get an OEM Z32 MAF. Walboro 255 is commonly used in turbo setups.

You're not near 300hp on stock tune / injectors / maf.
Frank_Jaeger is offline   Reply With Quote
Old 08-17-2014, 10:14 PM   #5
anti tyler
GM2 (SW/AW)
 
anti tyler's Avatar
 
Join Date: Jul 2008
Location: US
Posts: 3,260
Trader Rating: (37)
anti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond reputeanti tyler has a reputation beyond repute
Feedback Score: 37 reviews
Send a message via AIM to anti tyler Send a message via Yahoo to anti tyler
I don't think #1 has anything to do with being turbo. at all. I think you've got a dying ignition coil. Best $45 you can spend upgrading it to a blaster 2 coil.

#2 is an obvious sign of using an atmospheric blow off valve with a draw thru MAFs setup.

You should look into swapping your MAFs around to a draw through setup.

& if you'd like a Z32 air flow sensor I've got one with a pigtail for sale.
__________________
Quote:
WillEastS14:
mannn u whylin son.
but that shyt has SWAG

KA-T for life!
Current for sale advertisement

anti tyler is offline   Reply With Quote
Reply

Bookmarks

Tags
240sx, engine, fuel, ka24det, problems


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright 1998 - 2015, Zilvia.net