Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 12-25-2014, 09:00 PM   #1
mrtsb4
 
Join Date: Aug 2013
Location: Tampa Bay,FL
Posts: 23
Trader Rating: (0)
mrtsb4 is an unknown quantity at this point
Feedback Score: 0 reviews
KA KA24DE S14 idle problems

So I have high idle for my 96' 240, and I had it since I got the car which was a while ago. The last owner did a motor swap from a '97 KA auto.


So the thing is that the idle is constant and not hesitating but it it kind of high at around 1400 RPM sometimes. When I start my car in the morning the idle raises to 1500-1600 RPM then drop after a while of idling. At cold weather it drops to about 1000 RPM but on a hot day, especially when I turn my A/C on it is about 1600 RPM!!!!!


I checked many things, I know that it might be caused by the AUTO ECU but it is a manual ECU just like it should be. I checked that it might be the MAF because the prev. owner put a POS oil type air filter that ruins Mass Air Flow sensors, I unplugged it but nothing changed so it's not the prob. I did the same thing with the throttle position sensor (TPS). I recently cleaned my IACV inside out but it's the same shit.



I did a check engine light scan because it was on but it only showed problems of Speed sensor, and EVAP.
mrtsb4 is offline   Reply With Quote
Sponsored Links
Old 12-25-2014, 09:17 PM   #2
Javi802
Zilvia Junkie
 
Javi802's Avatar
 
Join Date: Jul 2012
Location: Oklahoma
Age: 26
Posts: 464
Trader Rating: (10)
Javi802 is an unknown quantity at this point
Feedback Score: 10 reviews
did you look for a vacuum leak?
Javi802 is offline   Reply With Quote
Old 12-25-2014, 09:29 PM   #3
mrtsb4
 
Join Date: Aug 2013
Location: Tampa Bay,FL
Posts: 23
Trader Rating: (0)
mrtsb4 is an unknown quantity at this point
Feedback Score: 0 reviews
I did spray some Brake cleaner after I knew IACV was not the problem. No raises in Idle
mrtsb4 is offline   Reply With Quote
Old 12-25-2014, 09:30 PM   #4
mrtsb4
 
Join Date: Aug 2013
Location: Tampa Bay,FL
Posts: 23
Trader Rating: (0)
mrtsb4 is an unknown quantity at this point
Feedback Score: 0 reviews
I forgot to mention that the car is in Open Loop mode (getting it fixed soon) but it shouldn't mess with the idle at all.
mrtsb4 is offline   Reply With Quote
Old 12-29-2014, 04:59 PM   #5
mrtsb4
 
Join Date: Aug 2013
Location: Tampa Bay,FL
Posts: 23
Trader Rating: (0)
mrtsb4 is an unknown quantity at this point
Feedback Score: 0 reviews
ideas anyone?
mrtsb4 is offline   Reply With Quote
Reply

Bookmarks

Tags
aac, iacv, idle, intake manifold, ka24


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™