Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 05-09-2018, 06:35 PM   #1
ParkerVX
 
ParkerVX's Avatar
 
Join Date: Apr 2018
Location: Hawaii
Age: 21
Posts: 9
Trader Rating: (0)
ParkerVX is an unknown quantity at this point
Feedback Score: 0 reviews
KA24E wiring harness problem?

Was cleaning my MAF today and put it all back together and after it had trouble idling. Wouldn't go over 2500 RPMs. So I went back an noticed if I wiggle my wiring harness around it has trouble idling. What would be the best route to take on this? I have no experience doing any harness swaps, or putting a new one in. Think if I bought a new maf pigtail/plug and just rewire it that would work?

Let me know what you guys think
Thank you

VIDEO LINK https://www.youtube.com/watch?v=YyTIs32vZKw

1990 240sx
ParkerVX is offline   Reply With Quote
Sponsored Links
Old 05-13-2018, 08:36 PM   #2
unicoder
Leaky Injector
 
unicoder's Avatar
 
Join Date: Apr 2017
Location: Alabama
Posts: 121
Trader Rating: (1)
unicoder is an unknown quantity at this point
Feedback Score: 1 reviews
If it won't go over 2500 RPMS, it's the MAF. Since it worked before, likely wiring.

You need to determine where the break is in the wires. Is it right at the plug? You may need to get a razor blade and peel back the loom and look at the wires to see where the problem is, then just replace the broken section.

If it is broken at the plug, then yeah get a pigtail and wire it up!
__________________
95 KA-T
unicoder is offline   Reply With Quote
Old 05-14-2018, 12:05 AM   #3
ParkerVX
 
ParkerVX's Avatar
 
Join Date: Apr 2018
Location: Hawaii
Age: 21
Posts: 9
Trader Rating: (0)
ParkerVX is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by unicoder View Post
If it won't go over 2500 RPMS, it's the MAF. Since it worked before, likely wiring.

You need to determine where the break is in the wires. Is it right at the plug? You may need to get a razor blade and peel back the loom and look at the wires to see where the problem is, then just replace the broken section.

If it is broken at the plug, then yeah get a pigtail and wire it up!
yea I wiggled it around and it fixed the 2500 rpm problem. I have yet to take it a part. Need a full day that I know I won't be doing any driving haha. Its the wires leading into the pigtail plug. Should be easy to fix (i hope) never done splicing or any rewiring but was watching a few videos.
ParkerVX is offline   Reply With Quote
Old 05-14-2018, 08:58 AM   #4
EFITTZY
Leaky Injector
 
EFITTZY's Avatar
 
Join Date: Mar 2016
Location: I n d i a n a
Age: 22
Posts: 117
Trader Rating: (0)
EFITTZY has a little shameless behavior in the past
Feedback Score: 0 reviews
Should be an easy fix! You can see the wires pulling out of the pins inside the plastic connector in your video. Get a new maf pigtail, and splice it into your harness. Make sure you solder it and heat shrink it.
Good Luck

Next time please post questions like this in the small questions thread.

Won't let me embed the link for some reason but here is the url:
http://zilvia.net/f/showthread.php?t=297481
__________________
(づ。◕‿‿◕。)づ T E A M B L O O M
EFITTZY is online now   Reply With Quote
Old 05-16-2018, 12:57 AM   #5
ParkerVX
 
ParkerVX's Avatar
 
Join Date: Apr 2018
Location: Hawaii
Age: 21
Posts: 9
Trader Rating: (0)
ParkerVX is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by EFITTZY View Post
Should be an easy fix! You can see the wires pulling out of the pins inside the plastic connector in your video. Get a new maf pigtail, and splice it into your harness. Make sure you solder it and heat shrink it.
Good Luck

Next time please post questions like this in the small questions thread.

Won't let me embed the link for some reason but here is the url:
http://zilvia.net/f/showthread.php?t=297481
thanks for the help. Going to order one and give it a try. Sorry about the wrong section, thanks for the help once again!
ParkerVX is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™