Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 12-24-2016, 10:11 AM   #1
Kamronman
 
Join Date: Jul 2012
Location: NorthWest
Posts: 29
Trader Rating: (1)
Kamronman is an unknown quantity at this point
Feedback Score: 1 reviews
SR Which o2 sensor do I need [S14 ecu running blacktop s13 motor]

Hi everyone, I am currently running an s14 power fc on my later model s13 blacktop motor. The pinouts are the same, just the harness is missing all the cam angle sensors etc (which are unnessesary for my motor to run).

I have ONE issue so far. My O2 sensor went out yesterday, I know because it reads only 0.00v, but when it picks up any voltage at all (when car cold starts or has been cooled down then restarted), it runs awesome, perfect afr's.

Btw, I have stock injectors, z32 maf, and a stovk power fc tune with minor adjustments to maf-voltage to dial in my afr's. (Recommended by a friend, and when I got the ecu had been tuned by a professional, these maf settings were set the same as I have them now).

Which o2 sensor do I need for compatability with kouki s14 motor?
Kamronman is offline   Reply With Quote
Sponsored Links
Old 12-24-2016, 10:13 AM   #2
Kamronman
 
Join Date: Jul 2012
Location: NorthWest
Posts: 29
Trader Rating: (1)
Kamronman is an unknown quantity at this point
Feedback Score: 1 reviews
I might as well add that I have my bov non-recirculated, will the added richness from that affect my o2 sensor life?
Kamronman is offline   Reply With Quote
Old 01-03-2017, 12:50 PM   #3
LoSt180
Zilvia Addict
 
LoSt180's Avatar
 
Join Date: May 2013
Location: MD
Posts: 637
Trader Rating: (16)
LoSt180 is an unknown quantity at this point
Feedback Score: 16 reviews
Late model S13 and S14 SR used the "fat" O2 sensor, just find a replacement. For my S14 SR I just ordered up a Bosch replacement for a 97 240sx and it was exactly the same as the SR one. The wire from the sensor to the connector is only about 12" long on the S14 (part # 13420), so if you need a longer wire, you can get one for a 96 300ZX (part # 13091), those leads are 22" long.

Costs about $35 from rockauto. Can also get from local autoparts store, they're not "SR20/JDM" specific parts.

S14 Bosch replacement on top, stock on bottom:
LoSt180 is offline   Reply With Quote
Old 01-04-2017, 07:34 PM   #4
Kingtal0n
Post Whore!
 
Kingtal0n's Avatar
 
Join Date: Jul 2005
Location: South Florida
Age: 34
Posts: 3,720
Trader Rating: (17)
Kingtal0n is on a distinguished road
Feedback Score: 17 reviews
Send a message via AIM to Kingtal0n
you can use any narrowband sensor on the planet, even a 1-wire from a chevy truck in the 80's would work. just make sure you match up the signal wire to the ecu and it will work.
__________________
build thread
http://tinyurl.com/n7rryt8
Kingtal0n is offline   Reply With Quote
Old 01-04-2017, 09:00 PM   #5
jedi03
Zilvia Addict
 
Join Date: Jul 2008
Location: albuquerque
Posts: 911
Trader Rating: (7)
jedi03 is an unknown quantity at this point
Feedback Score: 7 reviews
96 maxima plugs into my s13 blacktop...wiring is about 2 ft long...
jedi03 is offline   Reply With Quote
Reply

Bookmarks

Tags
kouki, t28


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:54 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™