Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 06-17-2017, 01:23 AM   #1
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
KA Possible Bad MAF? Help me please.

I have a infamous 240sx idle issue. Im bogging something awful and a horrid shake under load till around 2k then after that it's nearly normal. The weird thing is if i spray some b12 carb cleaner directly on my pod filter it seems to idle normally. I have dumped around 4k into my engine bay just trying to not make it 4.5k. I guess a silver lining is that everything is new but, realistically could have just sr swapped it.


I have replaced the tps twice (first one was faulty), injectors, fuel pump, spark plugs and wires, cap and rotor, ignition coil, engine (yes a new engine), fuel filters like 1 month old, o2 sensors pretty new, clutch, flywheel, battery is 5 months old, alternators tested, water pump, oil pump, etc.

basically everything but iacv, maf, knock sensor, and i guess ecu.
JettNebulis is offline   Reply With Quote
Sponsored Links
Old 06-17-2017, 07:19 AM   #2
drb5721
Leaky Injector
 
Join Date: Dec 2015
Location: nc
Age: 27
Posts: 77
Trader Rating: (1)
drb5721 is an unknown quantity at this point
Feedback Score: 1 reviews
Unplug the MAF and see how it runs. The fact sparying a combustible chemical in the intake stream make it idle better points more towards fuel. Possibly bad gas? Or a bad replacement fuel pump? Have you checked fuel pressure? Maybe a bad fuel pressure regulator?
drb5721 is offline   Reply With Quote
Old 06-21-2017, 04:05 PM   #3
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by drb5721 View Post
Unplug the MAF and see how it runs. The fact sparying a combustible chemical in the intake stream make it idle better points more towards fuel. Possibly bad gas? Or a bad replacement fuel pump? Have you checked fuel pressure? Maybe a bad fuel pressure regulator?
It's a maf based issue I unplug it and it runs great. I have a different issue now bought a new maf and it's doin the same thing. Could​ it be my pod?
JettNebulis is offline   Reply With Quote
Old 06-21-2017, 07:30 PM   #4
drb5721
Leaky Injector
 
Join Date: Dec 2015
Location: nc
Age: 27
Posts: 77
Trader Rating: (1)
drb5721 is an unknown quantity at this point
Feedback Score: 1 reviews
It is possible you got a faulty maf. Ask me how i know lol. If you bought it from a parts store it will have a warranty. Clear ecu codes and start the car with the maf plugged in. Let it run for a minute or so. Restarting is ok. Then check codes again. See if you get a maf code.. Make sure the screw on the ecu is turned all the way clockwise before running the car so it actually picks up on issues.

Also, if you think its a filter issue, you could just take the filter off for one quick start and see what happens.
drb5721 is offline   Reply With Quote
Old 06-21-2017, 08:07 PM   #5
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by drb5721 View Post
It is possible you got a faulty maf. Ask me how i know lol. If you bought it from a parts store it will have a warranty. Clear ecu codes and start the car with the maf plugged in. Let it run for a minute or so. Restarting is ok. Then check codes again. See if you get a maf code.. Make sure the screw on the ecu is turned all the way clockwise before running the car so it actually picks up on issues.

Also, if you think its a filter issue, you could just take the filter off for one quick start and see what happens.
I just bought a new pod because my old one was pretty thrashed anyways it didn't help. I never got a cel code. In going to return it and say it's faulty.
JettNebulis is offline   Reply With Quote
Reply

Bookmarks

Tags
bogging, help ka24de problem, idle problems, ka24de, shakes


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™