Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 07-08-2018, 11:40 PM   #1
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
95' KA24DE Sluggish and Jerks

Wassup guys,

Need some help diagnosing an issue I have. I've been searching the forums and google and still haven't been able to solve the issue.

95' KA24DE - 5 speed swapped

Acceleration is very sluggish and I have no torque at all. This car feels like a single cam honda. Also randomly during acceleration, mechanical power will cut while i still have my foot on the gas and the car will stop accelerating. Instead it will jerk. I usually have to let it jerk until it stops or throw it in neutral, wait a little bit, and then get back into gear and hope the jerking has stopped. It only happens under acceleration and its random. I've tried testing to see if I could find some type of pattern on when it occurs but it happens out of no where.

Car is OBD1 and I only have 2 CODES:
82 - Crank Shaft Position Sensor
84- Automatic Tranny to Fuel Injection Communication Line

Things I have done:
-Changed Spark Plugs
-Changed Fuel Filter
-Changed Fuel Pump
-Changed New Injectors
-Cleaned the MAF
-Compression test: 170psi across all cylinders
-Cleaned Idle Air Control Valve
-Distributor and Rotor are new
-Timing's been checked
-No Vacuum leaks..I've sprayed carb cleaner on the hoses, no change in idle
-Checked the grounds, all seem intact. I have yet to test them with an multimeter though

Things I might consider:
Knock Sensor?
TPS?
Coolant Temperature Sensor?
Change ECU? - Currently using an Automatic OBDII ECU.
Clogged cat?

Those are the only things I've come across that could possibly be the issue? Not sure if the codes the ecu are throwing would have anything to do with how the car runs? It doesn't misfire or anything.

HALP.
Kidshifty88 is offline   Reply With Quote
Sponsored Links
Old 07-09-2018, 01:53 AM   #2
snafupossum
Zilvia Member
 
Join Date: Nov 2008
Location: houston, tx
Age: 28
Posts: 203
Trader Rating: (1)
snafupossum is an unknown quantity at this point
Feedback Score: 1 reviews
Id start with the error code and look at the crank angle sensor
__________________
snafupossum is offline   Reply With Quote
Old 07-09-2018, 09:48 AM   #3
FaLKoN240
Super Moderator
 
FaLKoN240's Avatar
 
Join Date: Jun 2004
Location: SF Bay Area
Posts: 16,095
Trader Rating: (72)
FaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfection
Feedback Score: 72 reviews
Quote:
Originally Posted by snafupossum View Post
Id start with the error code and look at the crank angle sensor
I was going to suggest this. Why don't you address the code?

Also, google to see how other people have taken care of that automatic fuel code.
__________________

Best way to do business with me? Make your best offer FIRST.
FaLKoN240 is offline   Reply With Quote
Old 07-09-2018, 12:16 PM   #4
unicoder
Leaky Injector
 
unicoder's Avatar
 
Join Date: Apr 2017
Location: Alabama
Posts: 121
Trader Rating: (1)
unicoder is an unknown quantity at this point
Feedback Score: 1 reviews
I have a 95 KA. And the crank sensor isn’t even connected and I have no code. You might just need to worry about that fuel code

Also you need to check your TPS and make sure it’s operating correctly
__________________
95 KA-T
unicoder is online now   Reply With Quote
Old 07-09-2018, 01:18 PM   #5
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by FaLKoN240 View Post
I was going to suggest this. Why don't you address the code?

Also, google to see how other people have taken care of that automatic fuel code.
Yeah I looked online to see if people corrected the automatic fuel injection code (84), but no luck. Every person online that mentioned the code ended up ignoring it and moved onto their other codes LOL. But they had knock sensor codes and TPS codes which was giving them their sluggish acceleration issues. But I'll keep searching.

And then code (82) crank position sensor various people said it does not affect the car. My friend doesn't have his Crank Position Sensor connected either, but his car runs great. No issues whatsoever. It's used to detect misfiring but that's it. My car isn't misfiring. Idle is steady at 900-1000 rpm.

I been searching google, zilvia, nico the past 3 weeks so decided to reach out. haha.
Kidshifty88 is offline   Reply With Quote
Old 07-09-2018, 01:22 PM   #6
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by unicoder View Post
I have a 95 KA. And the crank sensor isn’t even connected and I have no code. You might just need to worry about that fuel code

Also you need to check your TPS and make sure it’s operating correctly
Hmm. Interesting. I have an s13 tranny in my s14, so it has an s13 crank sensor, which isn't connected, so it's throwing a code. But your's isn't? Weird.

Yeah, tried searching a solution for the automatic fuel code, but no luck so far. I'll have to keep searching for it.

I am getting 5v into the TPS from the harness connecter, but I did not check the resistance of the TPS. I will check that today to make sure I am getting the correct resistance from the TPS. Thanks!
Kidshifty88 is offline   Reply With Quote
Old 07-09-2018, 01:22 PM   #7
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by snafupossum View Post
Id start with the error code and look at the crank angle sensor
Thanks man. I'll dive deeper into the codes. I've been told they dont affect the car, but maybe there's more to it.
Kidshifty88 is offline   Reply With Quote
Old 07-09-2018, 01:30 PM   #8
unicoder
Leaky Injector
 
unicoder's Avatar
 
Join Date: Apr 2017
Location: Alabama
Posts: 121
Trader Rating: (1)
unicoder is an unknown quantity at this point
Feedback Score: 1 reviews
Quote:
Originally Posted by Kidshifty88 View Post
Hmm. Interesting. I have an s13 tranny in my s14, so it has an s13 crank sensor, which isn't connected, so it's throwing a code. But your's isn't? Weird.

Yeah, tried searching a solution for the automatic fuel code, but no luck so far. I'll have to keep searching for it.

My cas broke during my trans removal and when I looked it up, it said for the 95’ one 1 cars it was more of a dummy sensor and not needed

I have never had a code for it though
__________________
95 KA-T
unicoder is online now   Reply With Quote
Old 07-12-2018, 09:09 PM   #9
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Took the car to a local shop. Dude works on s2000's, 240's r32's and 33's.

I got a call back from him and he said "man i dont know what the fuck is wrong with this car"

LMAOOOOOO!!! TPS and Knock Sensor time!!
Kidshifty88 is offline   Reply With Quote
Old 07-12-2018, 09:45 PM   #10
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
this is EXACTLY what its doing.

https://www.youtube.com/watch?v=X3ELh4GyK2E
Kidshifty88 is offline   Reply With Quote
Old 07-13-2018, 12:54 PM   #11
cerealwars
Leaky Injector
 
Join Date: Mar 2011
Location: Grand Rapids, MI
Age: 26
Posts: 131
Trader Rating: (3)
cerealwars is an unknown quantity at this point
Feedback Score: 3 reviews
What does it do in neutral? The problem illustrated in that video screams MAF.

Coincidentally, I have a MAF for sale... wink wink.
__________________
93 coupe - AutoX/Fun summer daily/Eternal project
cerealwars is offline   Reply With Quote
Old 07-13-2018, 06:24 PM   #12
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by cerealwars View Post
What does it do in neutral? The problem illustrated in that video screams MAF.

Coincidentally, I have a MAF for sale... wink wink.
In neutral the car is fine. Idle doesnt bounce. When i come to a stop and throw it in neutral it doesnt wanna stall. Idle is always at 800-1000rpm... only time anything weird happens is under acceleration... and it happens randomly..

What brand is the MAF my good sir? How old is it? Perfect working condition?
Kidshifty88 is offline   Reply With Quote
Old 07-13-2018, 07:49 PM   #13
cerealwars
Leaky Injector
 
Join Date: Mar 2011
Location: Grand Rapids, MI
Age: 26
Posts: 131
Trader Rating: (3)
cerealwars is an unknown quantity at this point
Feedback Score: 3 reviews
Ahhh never mind don't buy my MAF lol.

If you have a bad MAF the engine won't rev past 2500-3000 in neutral.
__________________
93 coupe - AutoX/Fun summer daily/Eternal project
cerealwars is offline   Reply With Quote
Old 07-13-2018, 11:09 PM   #14
Kidshifty88
Zilvia Member
 
Join Date: Jan 2016
Location: Northridge
Posts: 171
Trader Rating: (0)
Kidshifty88 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by cerealwars View Post
Ahhh never mind don't buy my MAF lol.

If you have a bad MAF the engine won't rev past 2500-3000 in neutral.
Ahhh limp mode hahahah. Yeah i can rev all the way up to redline lmao

Thanks though man. Appreciate the help.
Kidshifty88 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™