Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 06-25-2018, 08:07 PM   #1
Matt.tobey427
 
Join Date: Jun 2018
Location: NH
Posts: 1
Trader Rating: (0)
Matt.tobey427 is an unknown quantity at this point
Feedback Score: 0 reviews
240sx won't run please help

My 1997 s14 ka24de is having issues. The car has fuel pressure and spark and cranks but won't start. It only runs for a short time when I spray and prime into the throttle body. I recently changed out the intake manifold but im certain i got everything plugged in correctly. Just curious if anyone has ever had this problem and what it could be. Maybe a distributed or coil pack? Any info appreciated
Matt.tobey427 is offline   Reply With Quote
Sponsored Links
Old 06-26-2018, 09:59 PM   #2
nissansrdub
Zilvia Junkie
 
nissansrdub's Avatar
 
Join Date: Apr 2007
Location: Denver Colorado
Posts: 500
Trader Rating: (3)
nissansrdub is an unknown quantity at this point
Feedback Score: 3 reviews
Make sure the connectors near the ecu are plugged in. right under the dash


Sent from my iPhone using Tapatalk
nissansrdub is offline   Reply With Quote
Old 06-28-2018, 02:18 PM   #3
unicoder
Leaky Injector
 
unicoder's Avatar
 
Join Date: Apr 2017
Location: Alabama
Posts: 121
Trader Rating: (1)
unicoder is an unknown quantity at this point
Feedback Score: 1 reviews
If it runs on starter fluid, then it's a good chance that the issue is fuel related.

Autozone rents a set of NOID Lights you can hook up to your injector plugs to ensure they are firing correctly, if they are then it could be a fuel pressure issue.

Remember when you took the intake manifold off, you had to disconnect your fuel feed and return lines, and your fuel pressure regulator vacuum lines, and i think a harness ground as well, that grounds on the right side of the intake manifold towards the front of the engine. Make sure all of those are hooked up correctly to ensure fuel pressure is getting set and the injectors are indeed firing
__________________
95 KA-T
unicoder is offline   Reply With Quote
Old 06-28-2018, 02:49 PM   #4
staying_chuki
Leaky Injector
 
staying_chuki's Avatar
 
Join Date: Feb 2018
Location: Ocala Fl
Posts: 133
Trader Rating: (1)
staying_chuki is an unknown quantity at this point
Feedback Score: 1 reviews
You said it starts when you spray into the throttle body. Answered your own question bro, its fuel related you should be able to go from there and fix it easy.


Sent from my iPhone using Tapatalk
staying_chuki is offline   Reply With Quote
Reply

Bookmarks

Tags
240sx, ka24de, wont start


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™