Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 04-12-2018, 11:31 AM   #1
TIGGZ_S13
 
TIGGZ_S13's Avatar
 
Join Date: Aug 2012
Location: mexicali, b.c.
Age: 27
Posts: 11
Trader Rating: (0)
TIGGZ_S13 is an unknown quantity at this point
Feedback Score: 0 reviews
Angry Crank no start, no spark or fuel. 93 ka24de

I have a 93 ka24de which i had changed the motor on, the previous engine started knocking so i bout another engine. At first we couldnt get fuel, the pump wasnt priming and when i checked through i found the ECU with a burned diode (i think thats what its called). I changed out the ECU and got it to start. It ran for about 2 days and when idling it just shut off and now it wont start, its not the battery, its not the starter. Im not getting spark or fuel. I checked the fuses and found none blown. What else should i check? Could I maybe have a short or something causing these problems?

Thanks in advance for any input.
__________________
TEAM KRSH TST DMMIEZ-TIGGZ -N IF U DNT KNW NOW U KNW
TIGGZ_S13 is offline   Reply With Quote
Sponsored Links
Old 04-12-2018, 01:05 PM   #2
flartius
Leaky Injector
 
flartius's Avatar
 
Join Date: Apr 2017
Location: Huntsville, AL
Posts: 105
Trader Rating: (2)
flartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud offlartius has much to be proud of
Feedback Score: 2 reviews
Well both the coil and the fuel pump should be on a relay, so if you're fuses leading up to those are good then I would check the relays themselves to see if they are getting both the constant 12v power and getting the signal to energize the coil.

Once you figure out what isn't getting power when it is supposed to you can trace it back from there.
__________________
¯\_(ツ)_/¯
flartius is offline   Reply With Quote
Old 04-12-2018, 02:03 PM   #3
staying_chuki
Leaky Injector
 
staying_chuki's Avatar
 
Join Date: Feb 2018
Location: Ocala Fl
Posts: 133
Trader Rating: (1)
staying_chuki is an unknown quantity at this point
Feedback Score: 1 reviews
Could be wiring if you cut/spliced anything. Also injectors, i think the tool is called a noid light or something to check that.

Could be aloot of tings


Sent from my iPhone using Tapatalk
staying_chuki is offline   Reply With Quote
Old 04-14-2018, 09:15 PM   #4
kyral
Premium Member
 
kyral's Avatar
 
Join Date: Nov 2012
Location: wisconsin
Age: 26
Posts: 291
Trader Rating: (1)
kyral is making a name for him/her selfkyral is making a name for him/her self
Feedback Score: 1 reviews
your distributor can cause your injectors not to open cause it has the Crank angle sensor iirc

how do you know you didnt just fry out another ecu?

definately check for any blown fuses. and relays, relays can be easily checked by replacing with a known good relay. or using a multimeter and a 9v battery
__________________
The most threads never responded to.
kyral is offline   Reply With Quote
Old 05-02-2018, 11:16 AM   #5
TIGGZ_S13
 
TIGGZ_S13's Avatar
 
Join Date: Aug 2012
Location: mexicali, b.c.
Age: 27
Posts: 11
Trader Rating: (0)
TIGGZ_S13 is an unknown quantity at this point
Feedback Score: 0 reviews
Update to my problem. I removed the engine harness to have it checked, they found nothing but told me the distributor might be the problem since the diode or resistor (idk the correct term for it) that burned leads to the distributor. I reinstalled the harness and turned it on and it didnt have the fault anymore. Idk Wtf the problem was but its fixed now. Just removed and reinstalled the harness, same ecu.
__________________
TEAM KRSH TST DMMIEZ-TIGGZ -N IF U DNT KNW NOW U KNW
TIGGZ_S13 is offline   Reply With Quote
Reply

Bookmarks

Tags
cranknostart, ka24de


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™