Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 05-23-2017, 08:23 PM   #1
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
KA Ka24de two dead cylinders SOS!!

Alright where to begin. lets just start from the beginning. One night I was going out to meet some friend and my engine seized out of nowhere. So I let out a sigh and went "240 life". I should note my current problem wasn't happening during this time. I figured I would rebuild the motor rebuilt it. It did not want to hold idle and when I tried to drive it was sluggish. pulled it and bought a brand new motor from a shop figuring I did something wrong. I installed it and i currently have a similar issue. The engine will start and hold idle at around 800 (while chugging like a v8 and shaking the piss out of the car) but when I give it gas it jerks furiously. I started pulling plug wire till I narrowed down my issue and it was cylinders 1 and 2. see if i could move around the issue by moving injectors and switching wires nothing. I bought some b12 chemical carb cleaner and it ran normally for maybe 1-2 minutes then back to shit. spraying it anywhere worked iacv and throttle body. Someone help i've been trying to get my car running for like 4 months now. I just wanna drive again.

New stuff:
Clutch
Pressure plate
flywheel
throw out bearing
Engine
recently cleaned iacv
distributor cap
tps sensor
plugs
injectors
fuel pump
fuel filter
distributor connector
battery
temp sensors x2
JettNebulis is offline   Reply With Quote
Sponsored Links
Old 05-24-2017, 01:31 PM   #2
di-devol
Zilvia FREAK!
 
Join Date: Jun 2010
Location: Woodinville
Age: 36
Posts: 1,409
Trader Rating: (5)
di-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enough
Feedback Score: 5 reviews
Check your grounds.
__________________
di-devol is offline   Reply With Quote
Old 05-24-2017, 02:37 PM   #3
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
As long as there is only 3 grounds that have to be grounded to the engine they should be grounded.
JettNebulis is offline   Reply With Quote
Old 05-24-2017, 02:40 PM   #4
di-devol
Zilvia FREAK!
 
Join Date: Jun 2010
Location: Woodinville
Age: 36
Posts: 1,409
Trader Rating: (5)
di-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enough
Feedback Score: 5 reviews
It's a little odd that you had the same issue across two engines though. Has to be something you're missing.
__________________
di-devol is offline   Reply With Quote
Old 05-24-2017, 02:44 PM   #5
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
I know right. I'm going to a junkyard​ today to grab a injector see if swapping it out will do the trick. I am also going to check it's output make sure it's getting the right power.
JettNebulis is offline   Reply With Quote
Old 05-24-2017, 03:24 PM   #6
thegr8one013
Zilvia Junkie
 
Join Date: Jun 2006
Location: nassau, ny
Posts: 442
Trader Rating: (1)
thegr8one013 is an unknown quantity at this point
Feedback Score: 1 reviews
Sounds like something went bad in ur harness or ecu
thegr8one013 is offline   Reply With Quote
Old 05-24-2017, 03:34 PM   #7
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
Should I crack open my ecu to see if anything is fried.
JettNebulis is offline   Reply With Quote
Old 05-24-2017, 03:34 PM   #8
di-devol
Zilvia FREAK!
 
Join Date: Jun 2010
Location: Woodinville
Age: 36
Posts: 1,409
Trader Rating: (5)
di-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enoughdi-devol will become famous soon enough
Feedback Score: 5 reviews
Quote:
Originally Posted by JettNebulis View Post
I know right. I'm going to a junkyard​ today to grab a injector see if swapping it out will do the trick. I am also going to check it's output make sure it's getting the right power.
In your list you already said you did injectors, right?

Are you using parts from the old engine on this new one? Is it the same harness and ecu? Compression good? No ecu codes?

Where in Washington are you?
__________________
di-devol is offline   Reply With Quote
Old 05-24-2017, 08:05 PM   #9
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
Intake manifold and exhaust manifold are the only two old things. Same ECU and for the most part harness. I just got new wires today and got injectors from pick and pull it seemed to help a lot. I don't jerk around anymore and my idle is steady. I think I might have gotten a dud injector.

I'm from Puyallup.
JettNebulis is offline   Reply With Quote
Old 05-24-2017, 11:36 PM   #10
JettNebulis
 
Join Date: Jan 2016
Location: Washington
Posts: 17
Trader Rating: (0)
JettNebulis is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by di-devol View Post
In your list you already said you did injectors, right?

Are you using parts from the old engine on this new one? Is it the same harness and ecu? Compression good? No ecu codes?

Where in Washington are you?
It still chugs like a v8 and shakes a little, but I took her for a drive now I have some bad smoke coming out of the back of my engine it seems to be coming from my transmission. I say this because it was coming out of my shifter and center console.
JettNebulis is offline   Reply With Quote
Reply

Bookmarks

Tags
dead cylinder, help 240sx, ka24de, rough idle, rough idle stalling


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™