Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 07-21-2016, 09:52 PM   #1
Pygmy180
 
Join Date: Jul 2016
Location: California
Posts: 2
Trader Rating: (0)
Pygmy180 is an unknown quantity at this point
Feedback Score: 0 reviews
Fuel prime no spark. Ecu??

So doing an sr swap on my 240. First problem was I wasn't getting fuel prime now I fixed that but now I'm not getting spark I checked the CAS and the timing is all good but then I took an extra look at the ecu and saw this... Are those tabs important is there a fix or no I need a whole new ecu? Where can I buy one from a trust worthy person
Attached Images
File Type: jpeg image.jpeg (230.7 KB, 9 views)
Pygmy180 is offline   Reply With Quote
Sponsored Links
Old 07-22-2016, 03:41 AM   #2
cotbu
Post Whore!
 
cotbu's Avatar
 
Join Date: Sep 2005
Location: DE
Posts: 3,299
Trader Rating: (3)
cotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nice
Feedback Score: 3 reviews
unless they are stopping the plug from fully seating they are not the problem or issue.
open the ecu up, look and smell. check the plug side for pushed out pins. go through the wiring again. make friends with people, borrow an ecu. if this is your first swap you probably missed the coil pack and/or head ground.
__________________

LoverTechnologies "Half Broken Things!"
cotbu is offline   Reply With Quote
Old 07-22-2016, 05:15 AM   #3
rawgarage
Parts Supplier
 
rawgarage's Avatar
 
Join Date: Oct 2007
Location: h o u s t o n
Age: 28
Posts: 5,540
Trader Rating: (74)
rawgarage is an unknown quantity at this point
Feedback Score: 74 reviews
As long as the harness fits snug you should be fine
__________________
"Life isn't Hard, You're just Soft" - www.rawgarage.us
rawgarage is offline   Reply With Quote
Old 07-22-2016, 09:33 PM   #4
Pygmy180
 
Join Date: Jul 2016
Location: California
Posts: 2
Trader Rating: (0)
Pygmy180 is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by cotbu View Post
unless they are stopping the plug from fully seating they are not the problem or issue.
open the ecu up, look and smell. check the plug side for pushed out pins. go through the wiring again. make friends with people, borrow an ecu. if this is your first swap you probably missed the coil pack and/or head ground.
Thanks for the reply I'll check the ground again on the coil packs, and make sure my harness is as snug as possible. my brother has an ecu for his black top s13 sr20 I have red top. Is it safe to try his?
Pygmy180 is offline   Reply With Quote
Old 07-23-2016, 12:09 AM   #5
cotbu
Post Whore!
 
cotbu's Avatar
 
Join Date: Sep 2005
Location: DE
Posts: 3,299
Trader Rating: (3)
cotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nicecotbu is just really nice
Feedback Score: 3 reviews
If he has an e5 or e6, should work fine, but definitely if you're just verifying spark.

Sent from my SM-N910T using Tapatalk
__________________

LoverTechnologies "Half Broken Things!"
cotbu is offline   Reply With Quote
Reply

Bookmarks

Tags
ecu, no spark, sr20


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™