Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 08-01-2016, 11:54 PM   #1
Jokekill
 
Join Date: Mar 2015
Location: Coquitlam
Age: 23
Posts: 6
Trader Rating: (0)
Jokekill is an unknown quantity at this point
Feedback Score: 0 reviews
Boost controller not working!!!

Hey guys. I got a hand me down Depo Racing electronic boost controller. I got the square small controller, but the boost solenoid is like the one in the first picture.



My problem is the boost level won't go higher than stock boost, no matter how much gain I put on it. I suspect it was the boost solenoid. It does make a clicking sound and I see it arcing, as I discount and reconnect the wires to the boost solenoid, when the ignition is on. As soon as the car turns on I'm getting nothing from the boost solenoid wires. The wiring might also be wrong, but I can't find any instructions for my particular boost controller. If anyone's got one just like mine. It'll be great if you can show me from the boost solenoid when the RED and BLACK wires merge in to red and white, and goes in the control unit, showing me which wire goes where would be great. Basically, if you can show me the whole wire for the boost solenoid that would be great. I tried switching them, but I get the same results. They both arc and click when the ignition is on, and stops when the car is running. Please help guys!!! If something doesn't make sense I'll retype it or explain it. It is pretty difficult to explain this on paper. Please and thank you!!
Jokekill is offline   Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
boost contoller, sr20 240 s13 sr20det


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™